2014. április 27., vasárnap

A katasztrófa hete

Múlt hét péntek óta nem írtam semmit. Ez a több mint egy hét ugyanakkor nem telt el eseménytelenül. Mondhatom minden szempontból katasztrófális volt. Csak abban reménykedem, hogy a jövő héttől sikeresebb lesz a működésem.
Az időrendi sorrendiség igénye nélkül leírom a történéseket:

Saját magam
Itthon vagyok egy hete, az idő legnagyobb részében feküdtem, olvastam próbálatam a fül/szem/orr/torok stb. gyulladásomat kúrálni. A bal fülem még mindíg be van dugulva.

HeeksCNC
Megpróbáltam lefordítani a HeeksCNC nevű CAM szoftvert. Először Windowson. Nem jött össze. Elszállt valami agybeteg hibával a fordító.
Ezek után nekiálltam a friss ropogós Ubuntu 14.04 LTS-en. Ez utóbbival rengeteget küzdöttem. Végül is sikerült lefordítani. El is indult, majd amint megpróbálok egy új szerszámot létrehozni, segmentation fault-al elszáll. Még küzdhettem volna vele további napokat (valószínüleg az OpenCascade vs OCE és ezek verziói a baja), de nem a fordítás a célom, hanem használni akarom. Így felraktam a Windowsos hivatalos build próba verzióját. Ez legalább csak kifagyogat és, ha megvárom megy tovább. Probléma nincs megoldva, de egyenlőre nem is lesz.

FRDM-KE06Z
Rendeltem két ilyen boardot. Korábban vettem egy Pololu Sumo robotot a fiamnak, hogy valamikor összerakom. A robot váz már egy jó ideje össze van rakva, csak nem akartam Arduino-t rakni rá.

 
Helyette a KL25 alapú freedom boardal akartam megcsinálni Erich Steyger nyomán. Végül is nem tetszett a megoldással kapcsolatos 3.3V/5V mizéria így félretettem. Most kapóra jött, hogy megjelent ez a board, ami működik 5V-on is.



Azért vettem kettőt, hogy a robot összerakását követően is tudjak kisérletezni vele.
Az első hibát ott követtem el, hogy nem csak a kétsoros Arduino csatlakozókat forrasztottam be, hanem a végén keresztben lévő csatlakozót is. Ez viszont mechanikailag ütközik a sumo tolólapjába.
Semmi gond, ez jó lesz nekem későbbre. Elővettem a másikat, beforrasztottam a csatlakozókat immmár a keresztben lévő nélkül.
Pár nappal később, el akartam kezdeni játszani vele. Megpróbáltam felrakni rá egy gyári mintakódot. Azóta, csak a bootloader jön be, a programozó LED folyamatosan villog, a státusz szerint "Programming..." állapotban van. Örökre.
Sikerült egy féltéglát gyártanom belőle. Néhány óra keresgéléssel kiderítettem róla a semmit (pontosabban lehet, hogy Windows 7/8-on rendbe lehet rakni, de nekem már csak 8.1-em van). Egyenlőre az az állás, hogy kell egy új board.

3D Nyomtató
Az új nyomtatófej beüzemeléséhez kell még nyomtatnom egy alkatrészt. A ventilátor új tartóját. Ezzel immár harmadszor próbálkozom (az egész sztori pontos leírását már megírtam, csak még nem publikáltam, a jövő héten erőt veszek magamon és befejezem a félkész cikkeim egy részét). Letakarítottam a nyomtatót, szépen beállítottam mindent, elindítottam a nyomtatást.
Nem indult.
A fűtött platform fűtése kb. 85 foknál kikapcsolt, nem is tudtam visszakapcsolni. Pár nappal később megint megpróbáltam. A jelenség ugyanaz (legalább a fűtés elindult és nem távozott az örök vadászmezőkre).
Valahonnan homályosan emlékszem rá, hogy másnak is volt baja a platform fűtésével. Egy szilárdtest relével toldották meg a vezérlést. Mi bajom lehet? Kipróbálom.
Egy fél óra alatt sűrű anyázások közepette kivakartam a tápegységet a helyéről. Egyre inkább azt gondolom, hogy nem osztanék a tervezőknek "Excelence of engineering" díjat.
Bekötöttem egy SSR-t amit egy régi cuccból vakartam ki.
Nem indult el a fűtés.
Mérjünk.
Beállítom a multimétert 20V méréshatárra, rámérek az SSR vezérlésére, kiakad a műszer.
200V méréshatár: 178V. Hirtelen szétkapom az egészet. A táp magában, terhetlés nélkül: 178V.
Gondolkozom, lenyugszom. Ha ez igaz lenne akkor füst és amperszag lenne. Átkapcsolom a műszert 1000V méréshatárra, közli 12V. Azt hiszem, volt egy multiméterem.
Elővettem a régi féldöglött Metex-emet. Az normálisan 12V-ot mér mindenütt.
Visszakötöttem mindent, félreraktam a bontott SSR-t és beraktam egy újat.




Na ezzel elindult a fűtés. Az SSR piszokul melegszik. A 25A-es nem lesz elég (persze másik nincs itthon). Aláraktam átmenetileg egy hűtőbordát, hogy lássam mi sül ki az egészből.
Úgy látszik rendesen felfűtötte a platformot, de ez így félig kibelezve nem használható. Kell rendelnem egy nagyobb SSR-t. Ez persze megint idő amíg megjön.

Multiméter - folytatás
Az egész történet vége, hogy nincs egy működő, kultúrált multiméterem (építenem kéne egyet. :-D ).
A Metexem van vagy 25 éves. Neki volt engedélye kimúlni. Pontosabban nem halott csak ellenállást nem mér értelmezhetően (szerintem kontakthibás a kapcsoló).
A másik egy Maxwell - nekem ez valami Kínai gagyinak tűnik. A tudása miatt viszont ezért is kiadtam valami 15eFt-ot egy pár éve.
Megelégeltem az egészet. A Metex már nem létezik. A nagy nevű gyártókon (Fluke, Agilent) amit kapni lehet (Maxwell, Tenma, Conrad féle Voltcraft, stb.) fogalmam sincs melyik indul a műszer kategóriában és melyik gagyi.
Így vettem egy nagy levegőt és rendeltem egy viszonylag alap Agilent multimétert.


Ez ugyan 35eFt, de a gagyiból 2-3 kísérlettel elkölthetnék ugyanennyit hulladékokra, az eredmény meg kétes.
A dolog pozitívuma, hogy egy szállítási költség alatt eljön a féltégla FRDM board cseréje is.

És ami pozitív
Ez itt most csak lábjegyzetként: Kicsit megnyomtam és kivégeztem három labort (11-13) és az összes quizt az ARM tanfolyamból. Így már csak a 14-es labor és a 15-ös modul (nem értékelt) játék előállítása van hátra. Ez május 7-ig nem tűnik lehetetlennek.

Nincsenek megjegyzések:

Megjegyzés küldése